Rapid7 Vulnerability & Exploit Database

HP SiteScope Remote Code Execution

Back to Search

HP SiteScope Remote Code Execution

Disclosed
08/29/2012
Created
05/30/2018

Description

This module exploits a code execution flaw in HP SiteScope. It exploits two vulnerabilities in order to get its objective. An authentication bypass in the create operation, available through the APIPreferenceImpl AXIS service, to create a new account with empty credentials and, subsequently, uses the new account to abuse the UploadManagerServlet and upload an arbitrary payload embedded in a JSP. The module has been tested successfully on HP SiteScope 11.20 over Windows 2003 SP2 and Linux CentOS 6.3.

Author(s)

  • rgod <rgod@autistici.org>
  • juan vazquez <juan.vazquez@metasploit.com>

Platform

Linux,Windows

Development

References

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/multi/http/hp_sitescope_uploadfileshandler
msf exploit(hp_sitescope_uploadfileshandler) > show targets
    ...targets...
msf exploit(hp_sitescope_uploadfileshandler) > set TARGET < target-id >
msf exploit(hp_sitescope_uploadfileshandler) > show options
    ...show and set options...
msf exploit(hp_sitescope_uploadfileshandler) > exploit

Time is precious, so I don’t want to do something manually that I can automate. Leveraging the Metasploit Framework when automating any task keeps us from having to re-create the wheel as we can use the existing libraries and focus our efforts where it matters.

– Jim O’Gorman | President, Offensive Security

;