Vulnerability & Exploit Database

Back to search

VMware Hyperic HQ Groovy Script-Console Java Execution

This module uses the VMware Hyperic HQ Groovy script console to execute OS commands using Java. Valid credentials for an application administrator user account are required. This module has been tested successfully with Hyperic HQ 4.6.6 on Windows 2003 SP2 and Ubuntu 10.04 systems.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/multi/http/hyperic_hq_script_console

Authors

  • bcoles <bcoles [at] gmail.com>

References

Targets

  • Automatic
  • Windows
  • Linux
  • Unix CMD

Platforms

  • windows
  • linux
  • unix

Architectures

  • x86
  • cmd

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/multi/http/hyperic_hq_script_console msf exploit(hyperic_hq_script_console) > show targets ...targets... msf exploit(hyperic_hq_script_console) > set TARGET <target-id> msf exploit(hyperic_hq_script_console) > show options ...show and set options... msf exploit(hyperic_hq_script_console) > exploit