Vulnerability & Exploit Database

Back to search

OrientDB 2.2.x Remote Code Execution

This module leverages a privilege escalation on OrientDB to execute unsandboxed OS commands. All versions from 2.2.2 up to 2.2.22 should be vulnerable.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/multi/http/orientdb_exec

Authors

  • Francis Alexander - Beyond Security's SecuriTeam Secure Disclosure program
  • Ricardo Jorge Borges de Almeida ricardojba1 <Ricardo Jorge Borges de Almeida ricardojba1 [at] gmail.com>

References

Targets

  • Linux
  • Unix CMD
  • Windows

Platforms

  • linux
  • unix
  • windows

Architectures

  • x86
  • cmd

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/multi/http/orientdb_exec msf exploit(orientdb_exec) > show targets ...targets... msf exploit(orientdb_exec) > set TARGET <target-id> msf exploit(orientdb_exec) > show options ...show and set options... msf exploit(orientdb_exec) > exploit