Vulnerability & Exploit Database

Back to search

pfSense authenticated group member RCE

pfSense, a free BSD based open source firewall distribution, version <= 2.3.1_1 contains a remote command execution vulnerability post authentication in the system_groupmanager.php page. Verified against 2.2.6 and 2.3.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/unix/http/pfsense_group_member_exec

Authors

  • s4squatch
  • h00die

References

Targets

  • Automatic Target

Platforms

  • unix

Architectures

  • cmd

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/unix/http/pfsense_group_member_exec msf exploit(pfsense_group_member_exec) > show targets ...targets... msf exploit(pfsense_group_member_exec) > set TARGET <target-id> msf exploit(pfsense_group_member_exec) > show options ...show and set options... msf exploit(pfsense_group_member_exec) > exploit