Vulnerability & Exploit Database

Back to search

Havalite CMS Arbitary File Upload Vulnerability

This module exploits a file upload vulnerability found in Havalite CMS 1.1.7, and possibly prior. Attackers can abuse the upload feature in order to upload a malicious PHP file without authentication, which results in arbitrary remote code execution.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/unix/webapp/havalite_upload_exec

Authors

  • CWH
  • sinn3r <sinn3r [at] metasploit.com>

References

Targets

  • Generic (PHP Payload)
  • Linux x86

Platforms

  • linux
  • php

Architectures

  • php
  • x86

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/unix/webapp/havalite_upload_exec msf exploit(havalite_upload_exec) > show targets ...targets... msf exploit(havalite_upload_exec) > set TARGET <target-id> msf exploit(havalite_upload_exec) > show options ...show and set options... msf exploit(havalite_upload_exec) > exploit