Vulnerability & Exploit Database

Back to search

Webmin /file/show.cgi Remote Command Execution

This module exploits an arbitrary command execution vulnerability in Webmin 1.580. The vulnerability exists in the /file/show.cgi component and allows an authenticated user, with access to the File Manager Module, to execute arbitrary commands with root privileges. The module has been tested successfully with Webmin 1.580 over Ubuntu 10.04.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/unix/webapp/webmin_show_cgi_exec

Authors

  • Unknown
  • juan vazquez <juan.vazquez [at] metasploit.com>

References

Targets

  • Webmin 1.580

Platforms

  • unix

Architectures

  • cmd

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/unix/webapp/webmin_show_cgi_exec msf exploit(webmin_show_cgi_exec) > show targets ...targets... msf exploit(webmin_show_cgi_exec) > set TARGET <target-id> msf exploit(webmin_show_cgi_exec) > show options ...show and set options... msf exploit(webmin_show_cgi_exec) > exploit

Related Vulnerabilities

Related Modules