Rapid7 Vulnerability & Exploit Database

Wordpress Work The Flow Upload Vulnerability

Back to Search

Wordpress Work The Flow Upload Vulnerability

Disclosed
03/14/2015
Created
05/30/2018

Description

This module exploits an arbitrary PHP code upload in the WordPress Work The Flow plugin, version 2.5.2. The vulnerability allows for arbitrary file upload and remote code execution.

Author(s)

  • Claudio Viviani
  • Roberto Soares Espreto <robertoespreto@gmail.com>

Platform

PHP

Architectures

php

Development

References

  • WPVDB-7883
  • EDB-36640
  • PACKETSTORM-131294

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/unix/webapp/wp_worktheflow_upload
msf exploit(wp_worktheflow_upload) > show targets
    ...targets...
msf exploit(wp_worktheflow_upload) > set TARGET < target-id >
msf exploit(wp_worktheflow_upload) > show options
    ...show and set options...
msf exploit(wp_worktheflow_upload) > exploit

Time is precious, so I don’t want to do something manually that I can automate. Leveraging the Metasploit Framework when automating any task keeps us from having to re-create the wheel as we can use the existing libraries and focus our efforts where it matters.

– Jim O’Gorman | President, Offensive Security

;