Vulnerability & Exploit Database

Back to search

GlobalSCAPE CuteZIP Stack Buffer Overflow

This module exploits a stack-based buffer overflow vulnerability in version 2.1 of CuteZIP. In order for the command to be executed, an attacker must convince the target user to open a specially crafted zip file with CuteZIP. By doing so, an attacker can execute arbitrary code as the target user.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/windows/fileformat/cutezip_bof

Authors

  • C4SS!0 G0M3S <Louredo_ [at] hotmail.com>
  • juan vazquez <juan.vazquez [at] metasploit.com>

References

Targets

  • CuteZIP 2.1 / Windows Universal

Platforms

  • windows

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/windows/fileformat/cutezip_bof msf exploit(cutezip_bof) > show targets ...targets... msf exploit(cutezip_bof) > set TARGET <target-id> msf exploit(cutezip_bof) > show options ...show and set options... msf exploit(cutezip_bof) > exploit