Vulnerability & Exploit Database

Back to search

PHP apache_request_headers Function Buffer Overflow

This module exploits a stack based buffer overflow in the CGI version of PHP 5.4.x before 5.4.3. The vulnerability is due to the insecure handling of the HTTP headers. This module has been tested against the thread safe version of PHP 5.4.2, from "windows.php.net", running with Apache 2.2.22 from "apachelounge.com".

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/windows/http/php_apache_request_headers_bof

Authors

  • Vincent Danen
  • juan vazquez <juan.vazquez [at] metasploit.com>

References

Targets

  • Windows XP SP3 / Windows 2003 Server SP2 (No DEP) / PHP 5.4.2 Thread safe

Platforms

  • windows

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/windows/http/php_apache_request_headers_bof msf exploit(php_apache_request_headers_bof) > show targets ...targets... msf exploit(php_apache_request_headers_bof) > set TARGET <target-id> msf exploit(php_apache_request_headers_bof) > show options ...show and set options... msf exploit(php_apache_request_headers_bof) > exploit

Related Vulnerabilities

Related Modules