Rapid7 Vulnerability & Exploit Database

Avaya WinPMD UniteHostRouter Buffer Overflow

Back to Search

Avaya WinPMD UniteHostRouter Buffer Overflow

Disclosed
05/23/2011
Created
05/30/2018

Description

This module exploits a stack buffer overflow in Avaya WinPMD. The vulnerability exists in the UniteHostRouter service, due to the insecure usage of memcpy when parsing specially crafted "To:" headers. The module has been tested successfully on Avaya WinPMD 3.8.2 over Windows XP SP3 and Windows 2003 SP2.

Author(s)

  • AbdulAziz Hariri
  • Unknown
  • juan vazquez <juan.vazquez@metasploit.com>

Platform

Windows

Development

References

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/windows/misc/avaya_winpmd_unihostrouter
msf exploit(avaya_winpmd_unihostrouter) > show targets
    ...targets...
msf exploit(avaya_winpmd_unihostrouter) > set TARGET < target-id >
msf exploit(avaya_winpmd_unihostrouter) > show options
    ...show and set options...
msf exploit(avaya_winpmd_unihostrouter) > exploit

Time is precious, so I don’t want to do something manually that I can automate. Leveraging the Metasploit Framework when automating any task keeps us from having to re-create the wheel as we can use the existing libraries and focus our efforts where it matters.

– Jim O’Gorman | President, Offensive Security

;