Vulnerability & Exploit Database

Back to search

Enterasys NetSight nssyslogd.exe Buffer Overflow

This module exploits a stack buffer overflow in Enterasys NetSight. The vulnerability exists in the Syslog service (nssylogd.exe) when parsing a specially crafted PRIO from a syslog message. The module has been tested successfully on Enterasys NetSight 4.0.1.34 over Windows XP SP3 and Windows 2003 SP2.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/windows/misc/enterasys_netsight_syslog_bof

Authors

  • Jeremy Brown
  • rgod <rgod [at] autistici.org>
  • juan vazquez <juan.vazquez [at] metasploit.com>

References

Targets

  • Enterasys NetSight 4.0.1.34 / Windows XP SP3
  • Enterasys NetSight 4.0.1.34 / Windows 2003 SP2

Platforms

  • windows

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/windows/misc/enterasys_netsight_syslog_bof msf exploit(enterasys_netsight_syslog_bof) > show targets ...targets... msf exploit(enterasys_netsight_syslog_bof) > set TARGET <target-id> msf exploit(enterasys_netsight_syslog_bof) > show options ...show and set options... msf exploit(enterasys_netsight_syslog_bof) > exploit