Vulnerability & Exploit Database

Back to search

IBM WebSphere RCE Java Deserialization Vulnerability

This module exploits a vulnerability in IBM's WebSphere Application Server. An unsafe deserialization call of unauthenticated Java objects exists to the Apache Commons Collections (ACC) library, which allows remote arbitrary code execution. Authentication is not required in order to exploit this vulnerability.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/windows/misc/ibm_websphere_java_deserialize

Authors

  • Liatsis Fotios <Liatsis Fotios [at] liatsisfotios>

References

Targets

  • IBM WebSphere 7.0.0.0

Platforms

  • windows

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/windows/misc/ibm_websphere_java_deserialize msf exploit(ibm_websphere_java_deserialize) > show targets ...targets... msf exploit(ibm_websphere_java_deserialize) > set TARGET <target-id> msf exploit(ibm_websphere_java_deserialize) > show options ...show and set options... msf exploit(ibm_websphere_java_deserialize) > exploit

Related Vulnerabilities