Rapid7 Vulnerability & Exploit Database

Yokogawa CS3000 BKESimmgr.exe Buffer Overflow

Back to Search

Yokogawa CS3000 BKESimmgr.exe Buffer Overflow

Disclosed
03/10/2014
Created
05/30/2018

Description

This module exploits an stack based buffer overflow on Yokogawa CS3000. The vulnerability exists in the BKESimmgr.exe service when handling specially crafted packets, due to an insecure usage of memcpy, using attacker controlled data as the size count. This module has been tested successfully in Yokogawa CS3000 R3.08.50 over Windows XP SP3 and Windows 2003 SP2.

Author(s)

  • juan vazquez <juan.vazquez@metasploit.com>
  • Redsadic <julian.vilas@gmail.com>

Platform

Windows

Development

References

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/windows/scada/yokogawa_bkesimmgr_bof
msf exploit(yokogawa_bkesimmgr_bof) > show targets
    ...targets...
msf exploit(yokogawa_bkesimmgr_bof) > set TARGET < target-id >
msf exploit(yokogawa_bkesimmgr_bof) > show options
    ...show and set options...
msf exploit(yokogawa_bkesimmgr_bof) > exploit

Time is precious, so I don’t want to do something manually that I can automate. Leveraging the Metasploit Framework when automating any task keeps us from having to re-create the wheel as we can use the existing libraries and focus our efforts where it matters.

– Jim O’Gorman | President, Offensive Security

;