Back to search

Yokogawa CS3000 BKFSim_vhfd.exe Buffer Overflow

This module exploits an stack based buffer overflow on Yokogawa CS3000. The vulnerability exists in the service BKFSim_vhfd.exe when using malicious user-controlled data to create logs using functions like vsprintf and memcpy in a insecure way. This module has been tested successfully on Yokogawa Centum CS3000 R3.08.50 over Windows XP SP3.

Free Metasploit Download

Get your copy of the world's leading penetration testing tool

 Download Now

Module Name

exploit/windows/scada/yokogawa_bkfsim_vhfd

Authors

  • Redsadic <julian.vilas [at] gmail.com>
  • juan vazquez <juan.vazquez [at] metasploit.com>

References

Targets

  • Yokogawa Centum CS3000 R3.08.50 / Windows XP SP3

Platforms

  • windows

Reliability

Development

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/windows/scada/yokogawa_bkfsim_vhfd msf exploit(yokogawa_bkfsim_vhfd) > show targets ...targets... msf exploit(yokogawa_bkfsim_vhfd) > set TARGET <target-id> msf exploit(yokogawa_bkfsim_vhfd) > show options ...show and set options... msf exploit(yokogawa_bkfsim_vhfd) > exploit