Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI 2: CVE-2019-3813: Security patch for spice (ALAS-2019-1184)

Back to Search

Amazon Linux AMI 2: CVE-2019-3813: Security patch for spice (ALAS-2019-1184)

Severity
5
CVSS
(AV:A/AC:M/Au:N/C:P/I:P/A:P)
Published
02/04/2019
Created
05/08/2020
Added
04/27/2020
Modified
05/01/2020

Description

Spice, versions 0.5.2 through 0.14.1, are vulnerable to an out-of-bounds read due to an off-by-one error in memslot_get_virt. This may lead to a denial of service, or, in the worst case, code-execution by unauthenticated attackers.

Solution(s)

  • amazon-linux-ami-2-upgrade-spice-debuginfo
  • amazon-linux-ami-2-upgrade-spice-server
  • amazon-linux-ami-2-upgrade-spice-server-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;