Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: CVE-2017-0898: Security patch for ruby24 ((Multiple Advisories))

Back to Search

Amazon Linux AMI: CVE-2017-0898: Security patch for ruby24 ((Multiple Advisories))

Severity
6
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:P)
Published
09/15/2017
Created
07/25/2018
Added
10/03/2017
Modified
09/19/2018

Description

Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value. Such situation can lead to a buffer overrun, resulting in a heap memory corruption or an information disclosure from the heap.

Solution(s)

  • amazon-linux-upgrade-ruby22
  • amazon-linux-upgrade-ruby23
  • amazon-linux-upgrade-ruby24

References

  • amazon-linux-upgrade-ruby22
  • amazon-linux-upgrade-ruby23
  • amazon-linux-upgrade-ruby24

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;