Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: CVE-2017-12613: Security patch for apr (ALAS-2017-928)

Back to Search

Amazon Linux AMI: CVE-2017-12613: Security patch for apr (ALAS-2017-928)

Severity
4
CVSS
(AV:L/AC:L/Au:N/C:P/I:N/A:P)
Published
10/23/2017
Created
07/25/2018
Added
12/07/2017
Modified
05/07/2019

Description

When apr_time_exp*() or apr_os_exp_time*() functions are invoked with an invalid month field value in Apache Portable Runtime APR 1.6.2 and prior, out of bounds memory may be accessed in converting this value to an apr_time_exp_t value, potentially revealing the contents of a different static heap value or resulting in program termination, and may represent an information disclosure or denial of service vulnerability to applications which call these APR functions with unvalidated external input.

Solution(s)

  • amazon-linux-upgrade-apr

References

  • amazon-linux-upgrade-apr

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;