Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: CVE-2017-17915: Security patch for GraphicsMagick (ALAS-2018-966)

Back to Search

Amazon Linux AMI: CVE-2017-17915: Security patch for GraphicsMagick (ALAS-2018-966)

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
12/27/2017
Created
07/25/2018
Added
03/09/2018
Modified
05/03/2019

Description

In GraphicsMagick 1.4 snapshot-20171217 Q8, there is a heap-based buffer over-read in ReadMNGImage in coders/png.c, related to accessing one byte before testing whether a limit has been reached.

Solution(s)

  • amazon-linux-upgrade-graphicsmagick

References

  • amazon-linux-upgrade-graphicsmagick

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;