Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: CVE-2017-7548: Security patch for postgresql94, postgresql95 (ALAS-2017-885)

Back to Search

Amazon Linux AMI: CVE-2017-7548: Security patch for postgresql94, postgresql95 (ALAS-2017-885)

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:N/I:P/A:N)
Published
08/10/2017
Created
07/25/2018
Added
09/01/2017
Modified
04/16/2020

Description

PostgreSQL versions before 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing remote authenticated attackers with no privileges on a large object to overwrite the entire contents of the object, resulting in a denial of service.

Solution(s)

  • amazon-linux-upgrade--postgresql95
  • amazon-linux-upgrade-postgresql94

References

  • amazon-linux-upgrade--postgresql95
  • amazon-linux-upgrade-postgresql94

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;