Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: CVE-2018-1000024: Security patch for squid (ALAS-2018-1081)

Back to Search

Amazon Linux AMI: CVE-2018-1000024: Security patch for squid (ALAS-2018-1081)

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
02/09/2018
Created
03/19/2019
Added
09/20/2018
Modified
05/07/2019

Description

The Squid Software Foundation Squid HTTP Caching Proxy version 3.0 to 3.5.27, 4.0 to 4.0.22 contains a Incorrect Pointer Handling vulnerability in ESI Response Processing that can result in Denial of Service for all clients using the proxy.. This attack appear to be exploitable via Remote server delivers an HTTP response payload containing valid but unusual ESI syntax.. This vulnerability appears to have been fixed in 4.0.23 and later.

Solution(s)

  • amazon-linux-upgrade-squid

References

  • amazon-linux-upgrade-squid

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;