Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: CVE-2018-1000079: Security patch for ruby20,ruby22,ruby23,ruby24 (ALAS-2018-983)

Back to Search

Amazon Linux AMI: CVE-2018-1000079: Security patch for ruby20,ruby22,ruby23,ruby24 (ALAS-2018-983)

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:P/A:N)
Published
03/13/2018
Created
07/25/2018
Added
04/06/2018
Modified
05/03/2019

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem could write to arbitrary filesystem locations during installation. This attack appear to be exploitable via the victim must install a malicious gem. This vulnerability appears to have been fixed in 2.7.6.

Solution(s)

  • amazon-linux-upgrade-ruby20
  • amazon-linux-upgrade-ruby22
  • amazon-linux-upgrade-ruby23
  • amazon-linux-upgrade-ruby24

References

  • amazon-linux-upgrade-ruby20
  • amazon-linux-upgrade-ruby22
  • amazon-linux-upgrade-ruby23
  • amazon-linux-upgrade-ruby24

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;