Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: CVE-2018-1060: Security patch for python27 ((Multiple Advisories))

Back to Search

Amazon Linux AMI: CVE-2018-1060: Security patch for python27 ((Multiple Advisories))

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
04/26/2018
Created
07/25/2018
Added
04/27/2018
Modified
05/07/2019

Description

python before versions 2.7.15, 3.4.9, 3.5.6rc1, 3.6.5rc1 and 3.7.0 is vulnerable to catastrophic backtracking in pop3lib's apop() method. An attacker could use this flaw to cause denial of service.

Solution(s)

  • amazon-linux-upgrade-python27
  • amazon-linux-upgrade-python34
  • amazon-linux-upgrade-python35
  • amazon-linux-upgrade-python36

References

  • amazon-linux-upgrade-python27
  • amazon-linux-upgrade-python34
  • amazon-linux-upgrade-python35
  • amazon-linux-upgrade-python36

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;