Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: CVE-2018-10858: Security patch for samba (ALAS-2018-1126)

Back to Search

Amazon Linux AMI: CVE-2018-10858: Security patch for samba (ALAS-2018-1126)

Severity
7
CVSS
(AV:N/AC:L/Au:S/C:P/I:P/A:P)
Published
08/14/2018
Created
03/19/2019
Added
01/25/2019
Modified
05/07/2019

Description

A heap-buffer overflow was found in the way samba clients processed extra long filename in a directory listing. A malicious samba server could use this flaw to cause arbitrary code execution on a samba client. Samba versions before 4.6.16, 4.7.9 and 4.8.4 are vulnerable.

Solution(s)

  • amazon-linux-upgrade-samba

References

  • amazon-linux-upgrade-samba

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;