Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: CVE-2019-1000018: Security patch for rssh (ALAS-2019-1328)

Back to Search

Amazon Linux AMI: CVE-2019-1000018: Security patch for rssh (ALAS-2019-1328)

Severity
5
CVSS
(AV:L/AC:L/Au:N/C:P/I:P/A:P)
Published
02/04/2019
Created
12/24/2019
Added
12/20/2019
Modified
12/20/2019

Description

rssh version 2.3.4 contains a CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in allowscp permission that can result in Local command execution. This attack appear to be exploitable via An authorized SSH user with the allowscp permission.

Solution(s)

  • amazon-linux-upgrade-rssh

References

  • amazon-linux-upgrade-rssh

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;