Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: CVE-2019-11041: Security patch for php72 ((Multiple Advisories))

Back to Search

Amazon Linux AMI: CVE-2019-11041: Security patch for php72 ((Multiple Advisories))

Severity
6
CVSS
(AV:N/AC:M/Au:N/C:P/I:N/A:P)
Published
08/09/2019
Created
09/21/2019
Added
09/19/2019
Modified
04/16/2020

Description

When PHP EXIF extension is parsing EXIF information from an image, e.g. via exif_read_data() function, in PHP versions 7.1.x below 7.1.31, 7.2.x below 7.2.21 and 7.3.x below 7.3.8 it is possible to supply it with data what will cause it to read past the allocated buffer. This may lead to information disclosure or crash.

Solution(s)

  • amazon-linux-upgrade--php73
  • amazon-linux-upgrade-php71
  • amazon-linux-upgrade-php72

References

  • amazon-linux-upgrade--php73
  • amazon-linux-upgrade-php71
  • amazon-linux-upgrade-php72

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;