Rapid7 Vulnerability & Exploit Database

Apache HTTPD: mod_mime Buffer Overread (CVE-2017-7679)

Back to Search

Apache HTTPD: mod_mime Buffer Overread (CVE-2017-7679)

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
06/20/2017
Created
07/25/2018
Added
06/20/2017
Modified
01/08/2018

Description

The affected asset is vulnerable to this vulnerability ONLY if it is running one of the following modules: mod_mime. Review your web server configuration for validation. mod_mime can read one byte past the end of a buffer when sending a malicious Content-Type response header.

Solution(s)

  • apache-httpd-upgrade-2_2_34
  • apache-httpd-upgrade-2_4_26

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;