Rapid7 Vulnerability & Exploit Database

Centos Linux: CVE-2017-2628: Moderate: curl security update (CESA-2017:0847)

Back to Search

Centos Linux: CVE-2017-2628: Moderate: curl security update (CESA-2017:0847)

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
03/12/2018
Created
08/29/2019
Added
08/28/2019
Modified
08/28/2019

Description

curl, as shipped in Red Hat Enterprise Linux 6 before version 7.19.7-53, did not correctly backport the fix for CVE-2015-3148 because it did not reflect the fact that the HAVE_GSSAPI define was meanwhile substituted by USE_HTTP_NEGOTIATE. This issue was introduced in RHEL 6.7 and affects RHEL 6 curl only.

Solution(s)

  • centos-upgrade-curl
  • centos-upgrade-curl-debuginfo
  • centos-upgrade-libcurl
  • centos-upgrade-libcurl-devel

References

  • centos-upgrade-curl
  • centos-upgrade-curl-debuginfo
  • centos-upgrade-libcurl
  • centos-upgrade-libcurl-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;