Rapid7 Vulnerability & Exploit Database

Centos Linux: CVE-2017-5648: Important: tomcat security update (CESA-2017:1809)

Back to Search

Centos Linux: CVE-2017-5648: Important: tomcat security update (CESA-2017:1809)

Severity
6
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:N)
Published
04/17/2017
Created
07/25/2018
Added
07/28/2017
Modified
03/03/2021

Description

While investigating bug 60718, it was noticed that some calls to application listeners in Apache Tomcat 9.0.0.M1 to 9.0.0.M17, 8.5.0 to 8.5.11, 8.0.0.RC1 to 8.0.41, and 7.0.0 to 7.0.75 did not use the appropriate facade object. When running an untrusted application under a SecurityManager, it was therefore possible for that untrusted application to retain a reference to the request or response object and thereby access and/or modify information associated with another web application.

Solution(s)

  • centos-upgrade-tomcat
  • centos-upgrade-tomcat-admin-webapps
  • centos-upgrade-tomcat-docs-webapp
  • centos-upgrade-tomcat-el-2-2-api
  • centos-upgrade-tomcat-javadoc
  • centos-upgrade-tomcat-jsp-2-2-api
  • centos-upgrade-tomcat-jsvc
  • centos-upgrade-tomcat-lib
  • centos-upgrade-tomcat-servlet-3-0-api
  • centos-upgrade-tomcat-webapps

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;