Rapid7 Vulnerability & Exploit Database

CentOS Linux: CVE-2021-3521: Moderate: rpm security update (CESA-2022:0368)

Free InsightVM Trial No Credit Card Necessary
Watch Demo See how it all works
Back to Search

CentOS Linux: CVE-2021-3521: Moderate: rpm security update (CESA-2022:0368)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
02/01/2022
Created
02/18/2022
Added
02/17/2022
Modified
05/25/2023

Description

There is a flaw in RPM's signature functionality. OpenPGP subkeys are associated with a primary key via a "binding signature." RPM does not check the binding signature of subkeys prior to importing them. If an attacker is able to add or socially engineer another party to add a malicious subkey to a legitimate public key, RPM could wrongly trust a malicious signature. The greatest impact of this flaw is to data integrity. To exploit this flaw, an attacker must either compromise an RPM repository or convince an administrator to install an untrusted RPM or public key. It is strongly recommended to only use RPMs and public keys from trusted sources.

Solution(s)

  • centos-upgrade-python3-rpm
  • centos-upgrade-python3-rpm-debuginfo
  • centos-upgrade-rpm
  • centos-upgrade-rpm-apidocs
  • centos-upgrade-rpm-build
  • centos-upgrade-rpm-build-debuginfo
  • centos-upgrade-rpm-build-libs
  • centos-upgrade-rpm-build-libs-debuginfo
  • centos-upgrade-rpm-cron
  • centos-upgrade-rpm-debuginfo
  • centos-upgrade-rpm-debugsource
  • centos-upgrade-rpm-devel
  • centos-upgrade-rpm-devel-debuginfo
  • centos-upgrade-rpm-libs
  • centos-upgrade-rpm-libs-debuginfo
  • centos-upgrade-rpm-plugin-fapolicyd
  • centos-upgrade-rpm-plugin-fapolicyd-debuginfo
  • centos-upgrade-rpm-plugin-ima
  • centos-upgrade-rpm-plugin-ima-debuginfo
  • centos-upgrade-rpm-plugin-prioreset
  • centos-upgrade-rpm-plugin-prioreset-debuginfo
  • centos-upgrade-rpm-plugin-selinux
  • centos-upgrade-rpm-plugin-selinux-debuginfo
  • centos-upgrade-rpm-plugin-syslog
  • centos-upgrade-rpm-plugin-syslog-debuginfo
  • centos-upgrade-rpm-plugin-systemd-inhibit
  • centos-upgrade-rpm-plugin-systemd-inhibit-debuginfo
  • centos-upgrade-rpm-sign
  • centos-upgrade-rpm-sign-debuginfo

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;