Rapid7 Vulnerability & Exploit Database

CentOS Linux: CVE-2022-2122: Moderate: gstreamer1-plugins-good security update (CESA-2023:2260)

Free InsightVM Trial No Credit Card Necessary
Watch Demo See how it all works
Back to Search

CentOS Linux: CVE-2022-2122: Moderate: gstreamer1-plugins-good security update (CESA-2023:2260)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
07/19/2022
Created
05/15/2023
Added
05/15/2023
Modified
05/25/2023

Description

DOS / potential heap overwrite in qtdemux using zlib decompression. Integer overflow in qtdemux element in qtdemux_inflate function which causes a segfault, or could cause a heap overwrite, depending on libc and OS. Depending on the libc used, and the underlying OS capabilities, it could be just a segfault or a heap overwrite.

Solution(s)

  • centos-upgrade-gstreamer1-plugins-good
  • centos-upgrade-gstreamer1-plugins-good-debuginfo
  • centos-upgrade-gstreamer1-plugins-good-debugsource
  • centos-upgrade-gstreamer1-plugins-good-gtk
  • centos-upgrade-gstreamer1-plugins-good-gtk-debuginfo
  • centos-upgrade-gstreamer1-plugins-good-qt-debuginfo

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;