Rapid7 Vulnerability & Exploit Database

Debian: CVE-2016-6294: php5, php7.0 -- security update

Back to Search

Debian: CVE-2016-6294: php5, php7.0 -- security update

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
07/25/2016
Created
07/25/2018
Added
07/27/2016
Modified
03/02/2020

Description

The locale_accept_from_http function in ext/intl/locale/locale_methods.c in PHP before 5.5.38, 5.6.x before 5.6.24, and 7.x before 7.0.9 does not properly restrict calls to the ICU uloc_acceptLanguageFromHTTP function, which allows remote attackers to cause a denial of service (out-of-bounds read) or possibly have unspecified other impact via a call with a long argument.

Solution(s)

  • debian-upgrade-php5
  • debian-upgrade-php7-0

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;