Vulnerability & Exploit Database

Back to search

Debian: CVE-2017-17807: linux -- security update

Severity CVSS Published Added Modified
2 (AV:L/AC:L/Au:N/C:N/I:P/A:N) December 20, 2017 December 24, 2017 January 17, 2018

Description

The KEYS subsystem in the Linux kernel before 4.14.6 omitted an access-control check when adding a key to the current task's "default request-key keyring" via the request_key() system call, allowing a local user to use a sequence of crafted system calls to add keys to a keyring with only Search permission (not Write permission) to that keyring, related to construct_get_dest_keyring() in security/keys/request_key.c.

Free Nexpose Download

Discover, prioritize, and remediate security risks today!

 Download now

References

Solution

debian-upgrade-linux

Related Vulnerabilities