Rapid7 Vulnerability & Exploit Database

Debian: CVE-2017-2620: qemu, qemu-kvm, xen -- security update

Back to Search

Debian: CVE-2017-2620: qemu, qemu-kvm, xen -- security update

Severity
9
CVSS
(AV:N/AC:L/Au:S/C:C/I:C/A:C)
Published
02/21/2017
Created
07/25/2018
Added
03/31/2017
Modified
02/24/2020

Description

Quick emulator (QEMU) before 2.8 built with the Cirrus CLGD 54xx VGA Emulator support is vulnerable to an out-of-bounds access issue. The issue could occur while copying VGA data in cirrus_bitblt_cputovideo. A privileged user inside guest could use this flaw to crash the QEMU process OR potentially execute arbitrary code on host with privileges of the QEMU process.

Solution(s)

  • debian-upgrade-qemu
  • debian-upgrade-qemu-kvm
  • debian-upgrade-xen

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;