Rapid7 Vulnerability & Exploit Database

Debian: CVE-2017-5637: zookeeper -- security update

Back to Search

Debian: CVE-2017-5637: zookeeper -- security update

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
06/01/2017
Created
07/25/2018
Added
06/03/2017
Modified
02/24/2020

Description

Two four letter word commands "wchp/wchc" are CPU intensive and could cause spike of CPU utilization on Apache ZooKeeper server if abused, which leads to the server unable to serve legitimate client requests. Apache ZooKeeper thru version 3.4.9 and 3.5.2 suffer from this issue, fixed in 3.4.10, 3.5.3, and later.

Solution(s)

  • debian-upgrade-zookeeper

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;