Rapid7 Vulnerability & Exploit Database

Debian: CVE-2017-6967: xrdp -- security update

Back to Search

Debian: CVE-2017-6967: xrdp -- security update

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
03/17/2017
Created
07/25/2018
Added
03/31/2017
Modified
02/24/2020

Description

xrdp 0.9.1 calls the PAM function auth_start_session() in an incorrect location, leading to PAM session modules not being properly initialized, with a potential consequence of incorrect configurations or elevation of privileges, aka a pam_limits.so bypass.

Solution(s)

  • debian-upgrade-xrdp

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;