Rapid7 Vulnerability & Exploit Database

Debian: CVE-2017-9214: openvswitch -- security update

Back to Search

Debian: CVE-2017-9214: openvswitch -- security update

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
05/23/2017
Created
02/23/2021
Added
02/22/2021
Modified
02/22/2021

Description

In Open vSwitch (OvS) 2.7.0, while parsing an OFPT_QUEUE_GET_CONFIG_REPLY type OFP 1.0 message, there is a buffer over-read that is caused by an unsigned integer underflow in the function `ofputil_pull_queue_get_config_reply10` in `lib/ofp-util.c`.

Solution(s)

  • debian-upgrade-openvswitch

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;