Rapid7 Vulnerability & Exploit Database

Debian: CVE-2019-10130: postgresql-11, postgresql-9.6 -- security update

Back to Search

Debian: CVE-2019-10130: postgresql-11, postgresql-9.6 -- security update

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:P/I:N/A:N)
Published
05/10/2019
Created
05/11/2019
Added
05/10/2019
Modified
07/07/2020

Description

A vulnerability was found in PostgreSQL versions 11.x up to excluding 11.3, 10.x up to excluding 10.8, 9.6.x up to, excluding 9.6.13, 9.5.x up to, excluding 9.5.17. PostgreSQL maintains column statistics for tables. Certain statistics, such as histograms and lists of most common values, contain values taken from the column. PostgreSQL does not evaluate row security policies before consulting those statistics during query planning; an attacker can exploit this to read the most common values of certain columns. Affected columns are those for which the attacker has SELECT privilege and for which, in an ordinary query, row-level security prunes the set of rows visible to the attacker.

Solution(s)

  • debian-upgrade-postgresql-11
  • debian-upgrade-postgresql-9-6

References

  • debian-upgrade-postgresql-11
  • debian-upgrade-postgresql-9-6

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;