Rapid7 Vulnerability & Exploit Database

Debian: CVE-2019-10782: checkstyle -- security update

Back to Search

Debian: CVE-2019-10782: checkstyle -- security update

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
01/30/2020
Created
02/13/2020
Added
02/12/2020
Modified
02/12/2020

Description

All versions of com.puppycrawl.tools:checkstyle before 8.29 are vulnerable to XML External Entity (XXE) Injection due to an incomplete fix for CVE-2019-9658.

Solution(s)

  • debian-upgrade-checkstyle

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;