Rapid7 Vulnerability & Exploit Database

Debian: CVE-2019-14818: dpdk -- security update

Back to Search

Debian: CVE-2019-14818: dpdk -- security update

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
11/14/2019
Created
11/15/2019
Added
11/14/2019
Modified
11/20/2019

Description

A flaw was found in all dpdk version 17.x.x before 17.11.8, 16.x.x before 16.11.10, 18.x.x before 18.11.4 and 19.x.x before 19.08.1 where a malicious master, or a container with access to vhost_user socket, can send specially crafted VRING_SET_NUM messages, resulting in a memory leak including file descriptors. This flaw could lead to a denial of service condition.

Solution(s)

  • debian-upgrade-dpdk

References

  • debian-upgrade-dpdk

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;