Rapid7 Vulnerability & Exploit Database

Debian: CVE-2019-15523: csync2 -- security update

Back to Search

Debian: CVE-2019-15523: csync2 -- security update

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Published
12/30/2020
Created
01/06/2021
Added
01/06/2021
Modified
01/06/2021

Description

An issue was discovered in LINBIT csync2 through 2.0. It does not correctly check for the return value GNUTLS_E_WARNING_ALERT_RECEIVED of the gnutls_handshake() function. It neglects to call this function again, as required by the design of the API.

Solution(s)

  • debian-upgrade-csync2

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;