Rapid7 Vulnerability & Exploit Database

Debian: CVE-2022-32212: nodejs -- security update

Back to Search

Debian: CVE-2022-32212: nodejs -- security update

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
07/14/2022
Created
10/07/2022
Added
10/07/2022
Modified
10/07/2022

Description

A OS Command Injection vulnerability exists in Node.js versions <14.20.0, <16.16.0, <18.5.0 due to an insufficient IsAllowedHost check that can easily be bypassed because IsIPAddress does not properly check if an IP address is invalid before making DBS requests allowing rebinding attacks.

Solution(s)

  • debian-upgrade-nodejs

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;