Rapid7 Vulnerability & Exploit Database

F5 Networks: K24322529 (CVE-2016-4449): libxml2 vulnerabilities CVE-2016-4447 and CVE-2016-4449

Back to Search

F5 Networks: K24322529 (CVE-2016-4449): libxml2 vulnerabilities CVE-2016-4447 and CVE-2016-4449

Severity
6
CVSS
(AV:N/AC:M/Au:N/C:P/I:N/A:P)
Published
06/09/2016
Created
07/25/2018
Added
02/16/2017
Modified
09/16/2019

Description

XML external entity (XXE) vulnerability in the xmlStringLenDecodeEntities function in parser.c in libxml2 before 2.9.4, when not in validating mode, allows context-dependent attackers to read arbitrary files or cause a denial of service (resource consumption) via unspecified vectors.

Solution(s)

  • f5-big-ip-upgrade-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;