Rapid7 Vulnerability & Exploit Database

F5 Networks: K81601350 (CVE-2017-6144): BIG-IP PEM vulnerability CVE-2017-6144

Back to Search

F5 Networks: K81601350 (CVE-2017-6144): BIG-IP PEM vulnerability CVE-2017-6144

Severity
6
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:N)
Published
07/12/2017
Created
07/25/2018
Added
07/14/2017
Modified
09/16/2019

Description

In F5 BIG-IP PEM 12.1.0 through 12.1.2 when downloading the Type Allocation Code (TAC) database file via HTTPS, the server's certificate is not verified. Attackers in a privileged network position may be able to launch a man-in-the-middle attack against these connections. TAC databases are used in BIG-IP PEM for Device Type and OS (DTOS) and Tethering detection. Customers not using BIG-IP PEM, not configuring downloads of TAC database files, or not using HTTP for that download are not affected.

Solution(s)

  • f5-big-ip-upgrade-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;