Rapid7 Vulnerability & Exploit Database

FreeBSD: (Multiple Advisories) (CVE-2016-9298): ImageMagick -- heap overflow vulnerability

Back to Search

FreeBSD: (Multiple Advisories) (CVE-2016-9298): ImageMagick -- heap overflow vulnerability

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:N/A:P)
Published
11/13/2016
Created
07/25/2018
Added
12/04/2016
Modified
05/07/2019

Description

Heap overflow in the WaveletDenoiseImage function in MagickCore/fx.c in ImageMagick before 6.9.6-4 and 7.x before 7.0.3-6 allows remote attackers to cause a denial of service (crash) via a crafted image.

Solution(s)

  • freebsd-upgrade-package-imagemagick
  • freebsd-upgrade-package-imagemagick-nox11
  • freebsd-upgrade-package-imagemagick7
  • freebsd-upgrade-package-imagemagick7-nox11

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;