Vulnerability & Exploit Database

Back to search

FreeBSD: VID-BEA84A7A-E0C9-11E7-B4F3-11BAA0C2DF21 (CVE-2017-15896): node.js -- Data Confidentiality/Integrity Vulnerability, December 2017

Severity CVSS Published Added Modified
6 (AV:N/AC:L/Au:N/C:P/I:P/A:N) December 08, 2017 December 14, 2017 January 17, 2018


Node.js was affected by OpenSSL vulnerability CVE-2017-3737 in regards to the use of SSL_read() due to TLS handshake failure. The result was that an active network attacker could send application data to Node.js using the TLS or HTTP2 modules in a way that bypassed TLS authentication and encryption.

Free Nexpose Download

Discover, prioritize, and remediate security risks today!

 Download now