Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2017-5940: Firejail: Privilege escalation

Back to Search

Gentoo Linux: CVE-2017-5940: Firejail: Privilege escalation

Severity
5
CVSS
(AV:L/AC:L/Au:N/C:P/I:P/A:P)
Published
02/09/2017
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

Firejail before 0.9.44.6 and 0.9.38.x LTS before 0.9.38.10 LTS does not comprehensively address dotfile cases during its attempt to prevent accessing user files with an euid of zero, which allows local users to conduct sandbox-escape attacks via vectors involving a symlink and the --private option. NOTE: this vulnerability exists because of an incomplete fix for CVE-2017-5180.

Solution(s)

  • gentoo-linux-upgrade-sys-apps-firejail
  • gentoo-linux-upgrade-sys-apps-firejail-lts

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;