Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2017-6349: Vim, gVim: Remote execution of arbitrary code

Back to Search

Gentoo Linux: CVE-2017-6349: Vim, gVim: Remote execution of arbitrary code

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
02/27/2017
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

An integer overflow at a u_read_undo memory allocation site would occur for vim before patch 8.0.0377, if it does not properly validate values for tree length when reading a corrupted undo file, which may lead to resultant buffer overflows.

Solution(s)

  • gentoo-linux-upgrade-app-editors-gvim
  • gentoo-linux-upgrade-app-editors-vim

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;