Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2021-32678: Nextcloud: Multiple Vulnerabilities

Back to Search

Gentoo Linux: CVE-2021-32678: Nextcloud: Multiple Vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Published
07/12/2021
Created
08/29/2022
Added
08/11/2022
Modified
08/11/2022

Description

Nextcloud Server is a Nextcloud package that handles data storage. In versions prior to 19.0.13, 20.0.11, and 21.0.3, ratelimits are not applied to OCS API responses. This affects any OCS API controller (`OCSController`) using the `@BruteForceProtection` annotation. Risk depends on the installed applications on the Nextcloud Server, but could range from bypassing authentication ratelimits or spamming other Nextcloud users. The vulnerability is patched in versions 19.0.13, 20.0.11, and 21.0.3. No workarounds aside from upgrading are known to exist.

Solution(s)

  • gentoo-linux-upgrade-www-apps-nextcloud

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;