Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2021-41177: Nextcloud: Multiple Vulnerabilities

Back to Search

Gentoo Linux: CVE-2021-41177: Nextcloud: Multiple Vulnerabilities

Severity
6
CVSS
(AV:N/AC:L/Au:S/C:P/I:N/A:P)
Published
10/25/2021
Created
08/29/2022
Added
08/11/2022
Modified
08/11/2022

Description

Nextcloud is an open-source, self-hosted productivity platform. Prior to versions 20.0.13, 21.0.5, and 22.2.0, Nextcloud Server did not implement a database backend for rate-limiting purposes. Any component of Nextcloud using rate-limits (as as `AnonRateThrottle` or `UserRateThrottle`) was thus not rate limited on instances not having a memory cache backend configured. In the case of a default installation, this would notably include the rate-limits on the two factor codes. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5, or 22.2.0. As a workaround, enable a memory cache backend in `config.php`.

Solution(s)

  • gentoo-linux-upgrade-www-apps-nextcloud

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;