Rapid7 Vulnerability & Exploit Database

Huawei EulerOS: CVE-2017-8397: binutils security update

Back to Search

Huawei EulerOS: CVE-2017-8397: binutils security update

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
05/01/2017
Created
09/26/2019
Added
09/25/2019
Modified
09/25/2019

Description

The Binary File Descriptor (BFD) library (aka libbfd), as distributed in GNU Binutils 2.28, is vulnerable to an invalid read of size 1 and an invalid write of size 1 during processing of a corrupt binary containing reloc(s) with negative addresses. This vulnerability causes programs that conduct an analysis of binary programs using the libbfd library, such as objdump, to crash.

Solution(s)

  • huawei-euleros-2_0_sp3-upgrade-binutils
  • huawei-euleros-2_0_sp3-upgrade-binutils-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;